[Solution] Astro errors on statup if FT installed

General AstroSynthesis discussion

[Solution] Astro errors on statup if FT installed

Postby Ed_NBOS » Mon Oct 17, 2011 12:07 am

If you are experiencing a bunch of Access Violations when you start AstroSynthesis and the program prompts you for whether or not you want to use FT as the terrain engine. This error relates to AV's in AstroSynthesis, not FT.

This occurs if:
You install both AstroSynthesis 3 and Fractal Terrains, and you try to run Astro3 first.
This only occurs if you did not have AstroSynthesis 2.0 installed on your computer.

The solution:
Download and run the program linked below. After the program launches, click the 'fix FT integration' button. Nothing will appear to happen, but it will create the necessary registry entries to get past this problem. Then launch Astro.

http://www.nbos.com/download/AstroFixit.exe

This is a one time action - once the registry entries are in place, the startup prompt asking about the Terrain engine is skipped. You can select which terrain engine to use in the Program Preferences window.

Astro itself will be altered to avoid this problem with the next update.
Ed_NBOS
Site Admin
 
Posts: 554
Joined: Wed Jul 08, 2009 12:16 am

Re: [Solution] Astro errors on statup if FT installed

Postby GrumpyOldFart » Tue Nov 27, 2012 2:34 pm

I don't have FT, and thus don't have this problem, but I do often have program freezes that seem to be tied to generating planetary maps in FWE. That is, it only freezes if I am in a system examining planets, and always freezes at "Scanning surface..."

That may help the troubleshooting process or may not, but there it is.
GrumpyOldFart
Torch Bearer
 
Posts: 11
Joined: Sun Nov 25, 2012 2:14 pm


Return to AstroSynthesis General

Who is online

Users browsing this forum: No registered users and 1 guest

cron